Bukobot 3D Printer Forum

News: Added the Bukobot Parts List (BOM) to Wiki at http://bukobot.com/bukobot-parts-list
Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: stepper motors moving x,y, and z axis only half distance  (Read 945 times)

ccruzen

  • Newbie
  • *
  • Posts: 2
    • View Profile
stepper motors moving x,y, and z axis only half distance
« on: May 21, 2013, 10:39:13 PM »
I started this thread because I need a bit of help calibrating the distance the stepper motors move the bed and extruder assembly. When I give manual commands in repeiter host, the motors are only moving their respective axis about half the distance of what i'm telling it to. x and y aren't too big of a deal as i could just tell it to print twice as large, but z kind of matters, as it doesn't move up enough, and will just smash the print around with the extruder nozzle. I noticed the problem after reinstalling the firmware following the instructions here: (http://bukobot.com/bukobot-marlin-configuration). not sure if it was doing this before then or not. 

I've got a Vanilla with an x3 control board, running it on windows 7.

anyone have any insight into how to fix this?

Tyson

  • Newbie
  • *
  • Posts: 42
    • View Profile
Re: stepper motors moving x,y, and z axis only half distance
« Reply #1 on: May 22, 2013, 06:46:09 PM »
Do your stepper driver boards have heatsinks on them?  Probably yes.   If so, you have newer steppers but that firmware was compiled for the older ones.   

If you compile your own you need:  #define DRV8825   

included in your configuration.h

This will be there in newer versions from:   https://github.com/whosawhatsis/Marlin.git


Tyson

  • Newbie
  • *
  • Posts: 42
    • View Profile
Re: stepper motors moving x,y, and z axis only half distance
« Reply #2 on: May 22, 2013, 07:59:43 PM »
I think you should grab from branch:  Bukobot_update

After choosing this branch, I just download via "ZIP" tab.   I didn't have any luck trying to use GitHub software.


ccruzen

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: stepper motors moving x,y, and z axis only half distance
« Reply #3 on: May 31, 2013, 02:13:17 AM »
sorry for the slow reply, was out of town on work for a bit, but you hit it right on the nose Tyson! yeah, i do have the newer board, but when i replaced the configuration.h file with the new one, it solved the issue nicely.

thanks for the help, i'd have never figured it out on my own  ;D

rod27cn

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: stepper motors moving x,y, and z axis only half distance
« Reply #4 on: January 25, 2014, 07:24:09 PM »
Hi,

I have the same problem as describe in the title, I download the new firmware in the link below:

http://bukobot.com/_media/marlin_duo.zip

But still my problem cannot be fix, my motor moving x, y and x axis only half distance of what I intended.

Please help.

Thanks!

BR
Rod

jit

  • Global Moderator
  • Full Member
  • *****
  • Posts: 174
    • View Profile
Re: stepper motors moving x,y, and z axis only half distance
« Reply #5 on: January 25, 2014, 11:26:26 PM »
Sounds like you might have the microstep jumpers set wrong.  Which jumpers to use depends on your hardware version (and firmware version too, I think).

See this thread:  http://forum.bukobot.com/index.php?topic=2822.0
Bukobot Duo v1

whosawhatsis

  • Administrator
  • Hero Member
  • *****
  • Posts: 598
    • View Profile
    • Whosawhatsis on G+
Re: stepper motors moving x,y, and z axis only half distance
« Reply #6 on: January 26, 2014, 03:59:36 AM »
Thanks for bringing this to our attention. I had forgotten that page was there, and the firmware there was out of date. I

rod27cn

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: stepper motors moving x,y, and z axis only half distance
« Reply #7 on: January 26, 2014, 05:17:05 PM »
hi whosawhatsis,

Thanks for your support, yes the new firmware update resolves this issue.
Thanks for your support.

BR
Rod

 

BloQcs design by Bloc
SMF 2.0.3 | SMF © 2011, Simple Machines