Bukobot 3D Printer Forum

Bukito Assembly Discussion => Bukito General Assembly => Topic started by: leo on April 07, 2014, 08:40:45 PM

Title: Y motor moves only one time after reboot
Post by: leo on April 07, 2014, 08:40:45 PM
Hello!
I have a new problem.
Y-motor takes and does only one command.
For eaxamlple:
After hard reboot Bukito it takes only one command for Y-movement.
Title: Re: Y motor moves only one time after reboot
Post by: whosawhatsis on April 09, 2014, 07:46:45 PM
Are you getting a "commads waiting" message, or any errors in the console? Does it take move commands for other axes before/after that?
Title: Re: Y motor moves only one time after reboot
Post by: leo on April 10, 2014, 05:29:22 AM
Are you getting a "commads waiting" message, or any errors in the console? Does it take move commands for other axes before/after that?
No. There are no errors and "commands waiting". I use Flight Check manual and manual control. Y-motor takes only one command independently of other commands.
I can move other motors before and after Y-motor.

Is it possible that short current brokes a piece of Bukito's "brain"?
Title: Re: Y motor moves only one time after reboot
Post by: whosawhatsis on April 16, 2014, 09:46:08 PM
So after the Y axis "takes one command", does it move the full distance requested, then refuse to move again? Does it make a difference if the first command is a (positive) jog command (like G1 Y100) or a home command (G28 Y0)? Is the motor locked after the move, or does it move freely?