Bukobot 3D Printer Forum

Software Installation & Setup => Mac OS X Specific Software => Topic started by: jimkirk on February 22, 2014, 08:36:44 PM

Title: Problem with Repetier
Post by: jimkirk on February 22, 2014, 08:36:44 PM
First time powering up...

I was going through the set-up procedure, fired up Repetier and set and saved all the various parameters, powered up and connected to the Bukobot, and started the Flight Check.  Tried moving X axis.

Repetier announced that a temperature was out of range and wouldn't move until the error was reset (that's from memory because now I can't reproduce the problem...)

I tried resetting the Bukobot several times, same thing happened.

Disconnected, quit Repetier and powered Bukobot down, measured the thermistor resistances (125 kOhms for the extruders, 120 kOhms for the bed at room temperature)

Then I tried connecting again, and Repetier freezes, and I have to force quit.  Nothing but the spinning beach ball...

Any suggestions?
Title: Re: Problem with Repetier
Post by: jimkirk on February 22, 2014, 10:53:46 PM
Forgot to mention, OSX Mavericks, installed the latest firmware...
Title: Re: Problem with Repetier
Post by: jit on February 23, 2014, 10:56:45 PM
Are you quite sure you have all of the thermistors connected to the correct terminals on the Azteeg?  (Some Azteegs have these marked strangely...)

I can't think of any sensible reason why you shouldn't be allowed to move in X because of a temperature measurement.  However, movement in X, Y or Z will be limited until you have homed that axis.

Also, see http://forum.bukobot.com/index.php?topic=3109.0 (http://forum.bukobot.com/index.php?topic=3109.0).
Title: Re: Problem with Repetier
Post by: whosawhatsis on February 24, 2014, 12:25:56 AM
That temperature error generally indicates that a thermistor is disconnected. Where did you measure the resistance? The most common place for this to be disconnected is at the screw terminals on the X carriage, but it could also mean that you have the thermistor plugged into the wrong port on the controller board.
Title: Re: Problem with Repetier
Post by: jimkirk on February 25, 2014, 04:06:49 AM
Thanks for the replies.  I measured the thermistors by unplugging them, inserting a 2 pin header in the sockets and measuring across that.  I have the hot bed thermistor plugged into the middle of the three positions, connected according to the diagram for the Azteeg3.  Re-plugged them in and no change.  My computer is in the middle of a multi-hour rendering, once that's done I'll try restarting and see if that clears things up.
Title: Re: Problem with Repetier
Post by: jimkirk on February 27, 2014, 11:10:15 PM
Still no joy.  I tried deleting Repetier and its preference file and re-installing the firmware on the Bukobot.

Here's the behavior of everything I've tried...

In Repetier I can go to printer settings and select printer (usbserial-DA005MG8), go through the various tabs for connection, behavior, dimension, advanced.  Checked that all the parameters make sense.  Apply and OK.

The text on the bottom of the window says "132 FPS Unknown printer firm...  Disconnected"

I can rotate and zoom the print volume graphic (though the rotate only takes effect after doing some sort of zoom).
Clicking on Temperature Curve replaces the 3D view with a blank gray rectangle.

Clicking on Load G-Code opens a search window, so that seems okay.

Clicking on Preferences opens up a preferences window showing 3D parameters , visualization quality and such, which responds when I click on things, however selecting configuration panels (host, slicer, 3D visualizations, color) is unresponsive.

In the main window clicking on Object Placement, Slicer, G-Code or Print Panel are unresponsive.

This seems to be about all I can do, and if I select the icon in the dock, I could quit the program, however as soon as I click on Connect, the program freezes and the dock says Force Quit.

After forced quitting and restarting there's a blue rectangle overlaying the Save as STL and Slice with Slic3r buttons saying Disconnected and the 3D view is an empty gray rectangle.  Load G-Code still responds, and this time I tried loading some G-Code (from my old Maker-bot) and it looks like it did load something, the 3D view came back, but was unresponsive beyond that.

And it still has the Unknown printer firm...  Disconnected at the bottom.

That's about all the symptom dump I can think of.  Thanks for any suggestions!
Title: Re: Problem with Repetier
Post by: whosawhatsis on February 28, 2014, 09:24:34 PM
Clearly there's something wrong with your Repetier Host install, but that shouldn't cause the temperature out-of-range error (BTW, there isn't an "out of range" error, there is a mintemp and a maxtemp error, which one were you seeing?).

In any case, I would recommend trying one of the alternative host programs (http://bukobot.com/software-to-install?&#alternative-host-software) (probably pronterface) to see if the printer is working, then you can either decide to use one of those instead of Repetier Host or go back to trying to get Repetier Host working. You may want to contact Repetier support at http://www.repetier.com/.